エラー

TypeScript

Constructor implementation is missing.ts(2390)の解決方法

Constructor implementation is missingが発生した時のコード 以下のコードだとエラーが発生してしまった。 class TodoController { constructor(privat...
エラー

【ERROR】The engine “node” is incompatible with this module. Expected version “14.17.1”. Got “14.18.0”の解決方法

yarn startを実行したら次のエラーが発生 error kato_pj_front@0.1.0: The engine "node" is incompatible with this module. Ex...
Golang

【Error】pq: SSL is not enabled on the serverの解決方法

GoでPostgreSQLに接続しようとしたらエラーが発生 database/sqlパッケージを使用して、Postgresにアクセスしようとしたら以下のエラーが発生してしまった。 pq: SSL is not enabled ...
JavaScript

【JS】Uncaught SyntaxError: Illegal continue statement: no surrounding iteration statementの対処法

Uncaught SyntaxError発生時の状況 Uncaught SyntaxError: Illegal continue statement: no surrounding iteration statement f...
Golang

【Golang】could not connect to database: sql: unknown driver “postgres” (forgotten import?) の解決方法

GolangからPostgresに接続しようとしたらエラーが発生 Golangで以下のようなコードを書き、sqlドライバーを使用してDBに接続しようとした。 package main import ( "data...
エラー

bundle installしたらMySQLのエラーでハマった時の対処法

bundle installしたらMySQLのところでエラーが発生したので、その解決方法をまとめました。 $ bundle install . . . Gem::Ext::BuildError: ERROR: Failed to b...
Ruby

Ruby 2.6.7がインストールできない時の解決方法とは?

rbenvからRubyの2.6.7をインストールする。 $ rbenv install 2.6.7 しかし、なぜか失敗する。他のバージョンでは問題ないのに。。。 【解決方法】 先頭に以下のおまじないを付けて...
エラー

An error occurred while installing thin (1.7.2), and Bundler cannot continue.の解決方法

Railsの環境構築中にbundle installをしたところ、以下のようなエラーが発生。どうやらthinというgemがエラーの原因となってる模様。とりあえずthinをインストールする必要があるみたい。 Gem::Ext::Bui...
Rails

bundle installしたらtherubyracerとlibv8のエラーでハマった

Railsの開発環境を構築している時に、bundle installしたら以下のエラーに遭遇。 $ bundle install The dependency tzinfo-data (>= 0) will be unused...
エラー

UnhandledPromiseRejectionWarning: Error: Can’t reach database server at `localhost`:`3306`の解決方法

npm run startでNestJSのプロジェクトを起動しようとしたら、以下のようなエラーが発生。 (node:1993) UnhandledPromiseRejectionWarning: Error: Can't r...
タイトルとURLをコピーしました